Help vt going crazy

Veloster Turbo Forum

Help vt going crazy

This is a discussion on Help vt going crazy within the Veloster Turbo Discussions forums, part of the Veloster Turbo Forum category; looking for some answers and going to give as much info as possible. about 2 weeks ago, i was getting off work and started my ...

Page 1 of 2 1 2 LastLast
Results 1 to 10 of 20
Like Tree1Likes

Thread: Help vt going crazy

  1. #1
    Senior Member
    This user has no status.
     
    mightymouse's Avatar
    Join Date
    Dec 2013
    Member
    #4673
    Location
    LaMarque Tx
    Posts
    324

    Help vt going crazy

    looking for some answers and going to give as much info as possible. about 2 weeks ago, i was getting off work and started my car to let it warm up. while standing on the outside of the car, i heard it idle really weird like it was stumbling. well I began to drive it home and noticed it felt a little under powered,but pulled strong. as the day gone on, the car was getting worse. i was running errands then i threw a cel. got it read at advance to the tune of my car was running lean (two codes said the same thing like at idle and i can't remember them off hand sorry) the car was obviously running pig rich at idle. the smell would burn your eyes!! black smoke accompanied this. took the advice of a friend and poured some octane booster thinking i got some bad gas. well a day and half later, the car returned to normal idle and seemed to drive okay. i went on vacation for 6 days and the car sat at the airport. drove it home and it was fine. well the other day, i decided to go WOT and hesitation and backfiring started.pulled the plugs and they were a rusty color(probably from the octane booster?) the gap remained the same as they was before. they are 1422's. mods are in my sig. now the reason i suspected bad gas is because the car was running great and pulling hard with issues, then out of nowhere with a full tank about a day after i filled up, this happens. going to replace my plugs tomorrow(i should be able to get a refund on them at o'reilly and purchase another set.they did the same when i cracked a plug in my c5zo6) and hopefully the car will be better. anything i could be missing??? possible bad pump in the tank??
    Sephiroth-14' Matte Gray VT- Tork 1.5 tune, tork 3inch catless DP, tork big gulp intake, tork fuel line, tork collars, solo 3inch exhaust, 18x8.5 AG 310's, ORIC intercooler and hot pipe, HKS BOV, 845cold pipe, Megan Street coilovers, RB mud flaps, m&s grille, CF Varient spoiler(duck bill).

  2. #2
    Senior Member
    This user has no status.
     
    mightymouse's Avatar
    Join Date
    Dec 2013
    Member
    #4673
    Location
    LaMarque Tx
    Posts
    324
    p2191 and p2187 were the codes
    Sephiroth-14' Matte Gray VT- Tork 1.5 tune, tork 3inch catless DP, tork big gulp intake, tork fuel line, tork collars, solo 3inch exhaust, 18x8.5 AG 310's, ORIC intercooler and hot pipe, HKS BOV, 845cold pipe, Megan Street coilovers, RB mud flaps, m&s grille, CF Varient spoiler(duck bill).

  3. #3
    Senior Member
    The Snail says
    "Wooooooosssh"
     
    Insanity Crow's Avatar
    Join Date
    Apr 2014
    Member
    #5431
    Location
    PA Someplace
    Posts
    511
    If you didn't look those codes up this is what they supposedly mean. Doesn't mean you have all of these issues, just a list of potential candidates.

    P2187
    - Leaking fuel injector or pressure regulator
    - High fuel pressure condition
    - Faulty front HO2S
    - Leak in exhaust system
    - MAF sensor faulty

    p2191
    Leaking fuel injector or pressure regulator
    - Faulty Mass Air Flow (MAF) sensor
    - High fuel pressure condition
    - Faulty front HO2S
    - Leak in exhaust system
    - Faulty PCV system
    This VT is out there somewhere, but it is no longer mine.....Pierce rear torsion bar, VT-One Strut Brace, 65-duro lower motor mount insert, Rigid Collars, K&N drop in air filter, MSW Type 25 16 inch wheels, Continental Purecontact Tires, very skinny driver

  4. Remove Advertisements
    VelosterTurbo.org
    Advertisements
     

  5. #4
    Senior Member
    This user has no status.
     
    mightymouse's Avatar
    Join Date
    Dec 2013
    Member
    #4673
    Location
    LaMarque Tx
    Posts
    324
    Quote Originally Posted by -X- View Post
    Start with inspecting the front O2 sensor. Don't you have Torque Pro? You can check the sensor voltage to get a preliminary status of it.

    "Pig rich at idle" is why I'm targeting the front O2 sensor first.

    Another easy check is the PCV valve.
    i don't have the torque app anymore phone got wiped.what should the voltage be?? and i have a catch can from tork and to be honest, had a little trouble locating the PCV when this first happend lol...embarrassed lol
    Sephiroth-14' Matte Gray VT- Tork 1.5 tune, tork 3inch catless DP, tork big gulp intake, tork fuel line, tork collars, solo 3inch exhaust, 18x8.5 AG 310's, ORIC intercooler and hot pipe, HKS BOV, 845cold pipe, Megan Street coilovers, RB mud flaps, m&s grille, CF Varient spoiler(duck bill).

  6. #5
    Senior Member
    This user has no status.
     
    Somerandom18's Avatar
    Join Date
    Sep 2015
    Member
    #7305
    Location
    Northeast Ohio
    Posts
    342
    Sounds like what my car did when I forgot to put that map sensor back in before starting it

    Sent from my Galaxy Note 4
    2015 A/T Ultra Black - Totaled

    2017 M/T WRB Pearl BRZ

    Stage 2 e85 tune | Header back Invidia exhaust | Tomei UEL header | Grimmspeed Intake and strut bar | Fluidampr Harmonic Damper | Cerma engine treatment /w Evo oil
    Rigid collars | Transmission and differential bushing inserts | Solid Driveshaft carrier bushings | Perrin steering rack locks | Continental DWS06 tires

  7. #6
    Senior Member
    This user has no status.
     
    mightymouse's Avatar
    Join Date
    Dec 2013
    Member
    #4673
    Location
    LaMarque Tx
    Posts
    324
    Quote Originally Posted by Somerandom18 View Post
    Sounds like what my car did when I forgot to put that map sensor back in before starting it

    Sent from my Galaxy Note 4
    did it clear up on it's own?? my car still back fires and stumbles....idles fine and no running rich though.
    Sephiroth-14' Matte Gray VT- Tork 1.5 tune, tork 3inch catless DP, tork big gulp intake, tork fuel line, tork collars, solo 3inch exhaust, 18x8.5 AG 310's, ORIC intercooler and hot pipe, HKS BOV, 845cold pipe, Megan Street coilovers, RB mud flaps, m&s grille, CF Varient spoiler(duck bill).

  8. #7
    Senior Member
    This user has no status.
     
    Somerandom18's Avatar
    Join Date
    Sep 2015
    Member
    #7305
    Location
    Northeast Ohio
    Posts
    342
    Well I just put the map sensor back in and it was fine :3

    Sent from my Galaxy Note 4
    2015 A/T Ultra Black - Totaled

    2017 M/T WRB Pearl BRZ

    Stage 2 e85 tune | Header back Invidia exhaust | Tomei UEL header | Grimmspeed Intake and strut bar | Fluidampr Harmonic Damper | Cerma engine treatment /w Evo oil
    Rigid collars | Transmission and differential bushing inserts | Solid Driveshaft carrier bushings | Perrin steering rack locks | Continental DWS06 tires

  9. #8
    Senior Member
    This user has no status.
     
    Sales@Tork2's Avatar
    Join Date
    Apr 2015
    Member
    #6797
    Location
    Auburn, Wa
    Posts
    533
    Start by checking your 02 sensor, if replacing it doesnt do the trick, i would get the torque app back and pull a datalog at idle and one under throttle when the problem is occurring. Does either sound like its an o2 sensor or a fueling issue. Your in tank pump could be shot too. Anyways, if it persists and you get a good datalog of it happening send it over to [email protected] and we can take a look to see where we are seeing the issue and hopefully get to the bottom of it
    Tyson
    Tork Motorsports Hours of Operation
    Monday-Friday: 10AM-7PM
    Saturdays: 12PM-6PM
    Please quote me to get a response

  10. #9
    Senior Member
    This user has no status.
     
    tobs54's Avatar
    Join Date
    Sep 2017
    Member
    #15905
    Posts
    153
    What was the conclusion to this? I have a p2191 right now. I've used my Ultragauge to clear it twice, and it just comes back. Took it to Hyundai and they tested the fuel pressure and said that was fine.
    They won't run any more tests because I have too many aftermarket parts. Any ideas? Below is a list of the mods causing Hyundai to not look at it any further.
    I checked the PCV valve, and all of my catch can connections before I cleared the code the first time.

    Beast mode intake
    Updated MAP sensor
    MBRP cat back exhaust
    SXTH hot pipe
    XE cold pipe
    60mm throttle body upgrade
    Catch can on the PCV side



    Sent from my SM-G930V using Tapatalk
    2016 Vitamin C VT w/ MT.

    Mods: Dual OCCs, DIY SRI, disabled upper clutch switch, 60mm TB with 4TBS; Xe ORCP and coolant bypass, SXTH hot pipe, MAP/IAT Sensor Upgrade, MBRP Catback Exhaust

  11. #10
    Senior Member
    Lit
     
    TooGqForYou's Avatar
    Join Date
    Apr 2016
    Member
    #7917
    Location
    Ventura, Ca
    Posts
    939
    Quote Originally Posted by tobs54 View Post
    What was the conclusion to this? I have a p2191 right now. I've used my Ultragauge to clear it twice, and it just comes back. Took it to Hyundai and they tested the fuel pressure and said that was fine.
    They won't run any more tests because I have too many aftermarket parts. Any ideas? Below is a list of the mods causing Hyundai to not look at it any further.
    I checked the PCV valve, and all of my catch can connections before I cleared the code the first time.

    Beast mode intake
    Updated MAP sensor
    MBRP cat back exhaust
    SXTH hot pipe
    XE cold pipe
    60mm throttle body upgrade
    Catch can on the PCV side



    Sent from my SM-G930V using Tapatalk
    I would remove catch cans & replace pcv valve if it hasn't been changed in the last 10k-15k- miles
    tobs54 likes this.
    2016 VT Elite White 7-Speed DCT Tech Package
    Turbosocks 3.5' SRI | 3' Straight Pipe Catback Exhaust | Res-Delete Pipe | Motors Line Front Strut Bar | XE 3TBS | XE ORCP | XE XWEK
    | XE XPVS | 60mm TB | TB Bypass | HKS M45XL Plugs | MAP Sensor 39300-84400 | PUP 5W-30 | Breather & PCV & Oil Cap CSS Venting-to-Atmosphere

Page 1 of 2 1 2 LastLast

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Search tags for this page

veloster turbo limp mode but no code

Click on a term to search for related topics.
Find us on Google+