Laggy WOT ???

Veloster Turbo Forum

Laggy WOT ???

This is a discussion on Laggy WOT ??? within the Veloster Turbo Discussions forums, part of the Veloster Turbo Forum category; I just bought a 2019 VT. Something I have noticed is that power seems to get worse the more you push on the throttle. At ...

Results 1 to 5 of 5

Thread: Laggy WOT ???

  1. #1
    Junior Member
    This user has no status.
     
    duffieboy's Avatar
    Join Date
    May 2019
    Member
    #21308
    Posts
    1

    Laggy WOT ???

    I just bought a 2019 VT. Something I have noticed is that power seems to get worse the more you push on the throttle. At about 1/4 throttle the car pulls hard, and is very responsive. So you would think if you slam the throttle to the floor it should be faster and pick up speed faster but that is not the case. It is noticeably slower when you go wide open throttle VS 1/4 ish throttle. Now most of the tests are at a starting speed of 100km/hr to 120km/hr. Does this seem normal ?? T

  2. #2
    Senior Member
    This user has no status.
     
    trdtoy's Avatar
    Join Date
    Apr 2014
    Member
    #5406
    Location
    North Carolina
    Posts
    2,517
    Welcome!

    What you're likely feeling is the torque curve of the stock tune and possibly diminishing power due to heat soak. All of this is normal.
    '15 Auto VT

    PB's with slips and video:

    60' ET 2.05
    1/8 ET 8.70
    1/8 MPH 85.68 MPH
    1/4 ET 13.421
    1/4 MPH 105.57 MPH

  3. #3
    Junior Member
    This user has no status.
     
    Swift_society's Avatar
    Join Date
    May 2019
    Member
    #21334
    Posts
    6
    So many variables , but my main question is why a wot box and how was it installed ? Do you have any other mods ?

  4. Remove Advertisements
    VelosterTurbo.org
    Advertisements
     

  5. #4
    Senior Member
    '14 VT Vitamin-C base manual
     
    RPW00Mirage's Avatar
    Join Date
    Sep 2013
    Member
    #4287
    Location
    Central MA
    Posts
    2,839
    Quote Originally Posted by Swift_society View Post
    So many variables , but my main question is why a wot box and how was it installed ? Do you have any other mods ?
    i think you're responding to the wrong thread?
    2012 Boston Red Veloster NA Base Manual BTRcc tuned 167whp / 138wtq SOLD! - TK.COM CAI/catback - Nameless poly motor mount - BTRcc 89 octane tune

    2014 Vitamin-C Veloster Turbo Base Manual
    K&N panel filter - Nameless poly motor mount - Curt hitch - CF filler cap - Hawk ceramic pads - PMS torsion bar - UNIQ front strut bar - DZIII tires

    2001 Emerald Green Kia Rio Manual
    Overhauled suspension - H&R springs - 1Gb control arms / torsion rods - A6D 1.6L DOHC swap complete!

  6. #5
    Junior Member
    This user has no status.
     
    PoeticRuins's Avatar
    Join Date
    May 2019
    Member
    #21412
    Location
    hope mills/fayetteville
    Posts
    3
    what kind of car did you have before this? i think i know what your talking about by the lag,it was like that with the other 2 cars i tested before the vt,its mostly a drivebywire thing your prob feeling,once youve spooled up the feeling should go away if your in a 6spd try dropping down a gear and see how it feels at a higher rpm

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Find us on Google+