Veloster Turbo Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
ok so im gonna get a video or something next time it happens and post it. i bought the veloster last yr i think at like 89k. 1 issue when i drive it for awhile turn it off, now this is random not everytime does this happen i took it into a hyundai dealership since its under warranty cost me 160 bucks they said nothing wrong because it didnt happen to them... so ok im at 97k now same issue drive it for awhile turn it off or even sometimes while im driving it just does it. starts like hard shifting revs go up to like 2.2k if im in park and its reving high, and i shift it o man its like the hole tranny moves the car when shifting... i tried something 1 day when it was high reving and i turned on my heater and it dropped the rpm but it did it again a few hrs ago and i did the heater trick and it still shifted hard. once it cools down back to normal. im so confused i got till 117k then its off warranty either needa break it or something or figure out what it is and fix before it cost me money in the long run, i really think its hurting my tranny when it does it.
 

·
Super Moderator
2015 auto VT, 2013 manual VT × 2
Joined
·
5,086 Posts
Take it to them when you have issues or leave it with them.
 

·
Super Moderator
2015 auto VT, 2013 manual VT × 2
Joined
·
5,086 Posts
For anyone here to remotely try to help you it will help to know the transmission, mods, and maybe a better description of the issue at hand in complete sentences.
 
1 - 4 of 4 Posts
Top