Veloster Turbo Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
68 Posts
Discussion Starter · #1 ·
I have never had a twin scroll so maybe i'm not used to to it but instead of a constant whistle while at full boost and hi rpms, it sounds a little choppy. My friend said it sounds like perhaps my waste gate is leaking boost? it has sounded like this since day one so i figured it was normal. I noticed it more after i unplugged the BPV hose from the intake and made it open atmosphere but now i'm kinda worried that it is an actual leak. Anyone else know what i'm talking about?
 

·
Registered
Joined
·
2,189 Posts
are you hitting the rev limiter? I hope not..... But by function it does spin in 2 cylinders per scroll. making it always receiving power from all four cylinder cycles. I would say try to just park the car and have someone press the accel to about 4.5-5k to hear it spool up and see if it sounds smooth... could be a misfire which I would think is unlikely.
I have never had a twin scroll so maybe i'm not used to to it but instead of a constant whistle while at full boost and hi rpm, it sounds a little choppy. My friend said it sounds like perhaps my waste gate is leaking boost? it has sounded like this since day one so i figured it was normal. I noticed it more after i unplugged the BPV hose from the intake and made it open atmosphere but now i'm kinda worried that it is an actual leak. Anyone else know what i'm talking about?
 

·
Registered
Joined
·
68 Posts
Discussion Starter · #3 ·
no rev limiter, it runs smooth but im just used to my old eclipse which was a constant whistle at full boost, this sounds like a choppy whistle, kinda hard to describe. Not a miss cause it doesn't lack power at all, just a weird turbo sound to me lol. I just don't know if its normal on these
 

·
Registered
Joined
·
68 Posts
Discussion Starter · #4 ·
is it a possibility that maybe air is going in through the BPV where the hose was disconnected? some kind of leak or something? it sounds like its either sucking A LOT of air through the new cone air filter, or leaking boost somewhere. Either way, just doesn't really sound normal
 

·
Registered
Joined
·
407 Posts
At 2/3 pedal on mine when merging into freeway traffic, I can feel that choppyness you describe in your turbo. I think the turbo is just creating more boost pressure than the throttle position is calling for. Therefore some excess pressure is being vented and your open BPV is just allowing you to hear it.
 

·
Registered
Joined
·
148 Posts
I've noticed this also. If you turn the radio down and presss the throttle it has a slight fluttering sound.
 

·
Registered
Joined
·
68 Posts
Discussion Starter · #7 ·
ok so its not just me lol, i thought i had done something when i took the hose off the bpv. Still don't know if its a good thing though, if you have a cone filter its twice as loud!
 

·
Registered
Joined
·
373 Posts
I've noticed this also. If you turn the radio down and press the throttle it has a slight fluttering sound.
Fluttering is usually air going BACK through the turbo and getting chopped up, or atleast that was the case in my old GTI :)

I really doubt theres a serious problem if you've been feeling/hearing it since you bought the car :) I did notice the vt is kind of jumpy on acceleration as well but I mean its a Hyundai not a Porsche
 

·
Registered
Joined
·
2 Posts
I have a question in regards of the turbo. When I test drove the car it had a sound whooshing everytime I let go of the accelerator or speed up. Now that I have my own I don't hear anything at all. Did they put a silencer or what is going on?
 
1 - 9 of 9 Posts
Top