Veloster Turbo Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Car is throwing camshaft position codes for a and b. Boost won't build. Just replaced the plugs and coil packs. Not sure what's going on but the turbo is sounding rough too.
 

·
Super Moderator
2014 Veloster Turbo Manual
Joined
·
4,121 Posts
what did you use for plugs and coils and what gap?
 

·
Administrator
2015 auto VT, 2013 manual VT × 2
Joined
·
6,320 Posts
Post all of the codes and anything else about the car that may be pertinent or no real help can be provided.
 

·
Registered
2016 VT M/T
Joined
·
58 Posts
Car is throwing camshaft position codes for a and b. Boost won't build. Just replaced the plugs and coil packs. Not sure what's going on but the turbo is sounding rough too.
Do you hear any unusual rattling (do not confuse for rod knock) sounds coming from the valve cover and timing cover area?

If yes, you have a bad chain tensioner and or stretched timing chain; DTC codes are pretty much telling you the engine is jumping timing and is having a hard time syncing the crank and camshaft positions.

Swap between the two cam sensors (right side of the valve cover) and use a shop scanner to verify the ECU reading between -13.xx- -14.xx.

Lastly, the VVT gears (cam phaser) may need to be replaced.
 

·
Administrator
2015 auto VT, 2013 manual VT × 2
Joined
·
6,320 Posts
I did. I posted the screenshot of the codes
Ngk Lazer iridium
Only posting generic things and not specific codes or specific spark plugs or any other pertinent information on the car you will not get good answers. Just from what you have posted it can be many things and many causes. Nothing there to help narrow things down.
 

·
Super Moderator
2014 Veloster Turbo Manual
Joined
·
4,121 Posts
no screenshots here in this thread, dickpool lol
 
1 - 8 of 8 Posts
Top