Veloster Turbo Forum banner
1 - 16 of 16 Posts

·
Registered
2016 Veloster Turbo
Joined
·
29 Posts
Discussion Starter · #1 ·
2016 Hyundai Veloster turbo Fbo and tuned with almost 70k miles, ran it hard on back roads and a cruise then after let it sit to cool down then Reved it as soon as I did the car became unresponsive and shut off lost all fuel pressure tried to start it and either no fuel or spark and just cranks
Light Black Font Screenshot Multimedia
 

·
Registered
2016 Veloster Turbo
Joined
·
29 Posts
Discussion Starter · #2 ·
YouTube video of car trying to start
 

·
Administrator
2015 auto VT, 2013 manual VT × 2
Joined
·
5,784 Posts
What all mods? You have torque app so you can monitor the fuel pressure easily to see if that's the issue.
 

·
Registered
2016 Veloster Turbo
Joined
·
29 Posts
Discussion Starter · #4 · (Edited)
Font Screenshot Parallel Rectangle Number

What all mods? You have torque app so you can monitor the fuel pressure easily to see if that's the issue.
Font Darkness Number Circle Computer


Fuel rail pressure was fine @1700psi then after it dropped to 20 psi which is wayy too low
 

·
Administrator
2015 auto VT, 2013 manual VT × 2
Joined
·
5,784 Posts
You have an evap issue and fuel pressure issue for sure. The latter will most likely be the cause of the hard to no start.

Do you have aftermarket fuel line or fuel pump?

Let the car cool all the way down where pressure is near 0. Press acc on but do not start and see what the rail pressure primes to. Do this a few times in a row. This will help narrow things down. Prime pressure should be around 5 bar.
 

·
Registered
2016 Veloster Turbo
Joined
·
29 Posts
Discussion Starter · #6 ·
You have an evap issue and fuel pressure issue for sure. The latter will most likely be the cause of the hard to no start.

Do you have aftermarket fuel line or fuel pump?

Let the car cool all the way down where pressure is near 0. Press acc on but do not start and see what the rail pressure primes to. Do this a few times in a row. This will help narrow things down. Prime pressure should be around 5 bar.

I don't have an aftermarket fuel line or fuel pump, the car started when I went to pick it up but after I went into boost it stalled and shut off, I checked the f/pump relay and fuse both were good no it's not working at all, I am going to test the fuel pump and check the voltage tomorrow hopefully it's just as simple as replacing the pump, but something tells me it's not, after all the fuel pump should last longer then 70k miles. Also do you think the evap canister could cause any problems ? I have never cleaned it since owning the car.
 

·
Administrator
2015 auto VT, 2013 manual VT × 2
Joined
·
5,784 Posts
Do what I said and report back on the rail pressure. Usually a pressure below 5 bar will indicate a pump failure if all else turns out well. It can also indicate a leak in a line or at the pump but that mostly occurs from an aftermarket install that's botched.
 

·
Registered
2016 Veloster Turbo
Joined
·
29 Posts
Discussion Starter · #8 ·
Ok, I will do that tomorrow, also I ordered a fuel line mine is still stock, and I ordered a Dw65c fuel pump, I mean I needed it anyways for 300whp in the future.
 

·
Administrator
2015 auto VT, 2013 manual VT × 2
Joined
·
5,784 Posts
Usually the oem fuel line and pump are ok on pump gas on the 16+ cars for that power level no issues. But you may have a dud! Lol! If you get them just be careful and do the installation properly as most screw it up especially the pump installation as there are no great instructions available.
 

·
Registered
2016 Veloster Turbo
Joined
·
29 Posts
Discussion Starter · #10 ·
Yeah Its going to be a challenge just going to go slow
 

·
Registered
2016 Veloster Turbo
Joined
·
29 Posts
Discussion Starter · #11 ·
Also I turn the car to the on position and left the fuel line unplugged and their was no fuel flowing,
 

·
Administrator
2015 auto VT, 2013 manual VT × 2
Joined
·
5,784 Posts
That will be the pump, pump fuse, relay, or pigtail itself. I seen all the above before. Keep us posted.
 

·
Registered
2016 Veloster Turbo
Joined
·
29 Posts
Discussion Starter · #14 ·
Hello, new fuel pump came it today so I installed it and the car turned on and seems to be running fine, also when I primed and let air out of the line the gas turned black then when to normal should that be of concern ?
 

·
Administrator
2015 auto VT, 2013 manual VT × 2
Joined
·
5,784 Posts
Be sure you have good gas, a clean tank, and a fresh filter sock.
 

·
Registered
2016 Veloster Turbo
Joined
·
29 Posts
Discussion Starter · #16 ·
Sounds good, unfortunately I had to use the old filter sock but I ordered one from Hyundaioemparts and I will be replacing it
 
1 - 16 of 16 Posts
Top