Veloster Turbo Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
OK..here's my story..My 2013 VT with only 8,000 miles on it would completely cut all acceleration (not stall though) when the RPM's were between 4-5K (basically defeating the whole purpose of having a turbo). Brought it to the dealer and they replace a sensor of some kind and that didn't fix it. So, they tell me they have to order a diagnostic tool in order to perform a certain test. 2 WEEKS later the tool comes in. They call me and say that the problem is the fuel pump. They replace it. Didn't fix problem. Finally, they call factory and factory advises them to replace fuel line(s). They replace fuel lines. PROBLEM SOLVED. They had my car for 28 freggin days! If this happens to your VT, let your dealer know about this post..it could save a LOT of time, money, and hassle!
 

·
Banned
Joined
·
7,377 Posts
OK..here's my story..My 2013 VT with only 8,000 miles on it would completely cut all acceleration (not stall though) when the RPM's were between 4-5K (basically defeating the whole purpose of having a turbo). Brought it to the dealer and they replace a sensor of some kind and that didn't fix it. So, they tell me they have to order a diagnostic tool in order to perform a certain test. 2 WEEKS later the tool comes in. They call me and say that the problem is the fuel pump. They replace it. Didn't fix problem. Finally, they call factory and factory advises them to replace fuel line(s). They replace fuel lines. PROBLEM SOLVED. They had my car for 28 freggin days! If this happens to your VT, let your dealer know about this post..it could save a LOT of time, money, and hassle!
Yeah we have had a few here with the problem.
 

·
Registered
Joined
·
2,375 Posts
when you say power is cut off is it all the time and does your BOV or BPV open up. mine cuts power about that time, when it does it the BOV opens up and my TC light starts flashing.
 

·
Registered
Joined
·
2,375 Posts
Go to the dealer. Have them check it out. Thats not right. Lol
it does only happen when i am accelerating hard and turning. i just figured the TC thought i was going into a ditch so it took my power.
 

·
Registered
Joined
·
2,375 Posts
ya i dont turn the TC off very much so i have not tried that yet. my VT was built in june of 2012 and i did get it with 15,000 miles on it so i would think those problems the first VT had would have been taken care of by the time i purchased the car.
 

·
Banned
Joined
·
7,377 Posts
ya i dont turn the TC off very much so i have not tried that yet. my VT was built in june of 2012 and i did get it with 15,000 miles on it so i would think those problems the first VT had would have been taken care of by the time i purchased the car.
Well if you have a possible problem get it diagnosed before it turns into a problem. Go out now. Turn off TC and duplicate the situation that caused it before. Do it now. Not tomorrow.

If you put it off and something happens don't come cry to us.
 

·
Registered
Joined
·
2,375 Posts
oh i wont come crying if something fails the car is mine i am paying for it, its my responsibility to take care of it not you guy's.
 

·
Registered
Joined
·
2,375 Posts
Go test it. Literally will take 5 minutes. Lol
lol i know i just have to figure out if i can get it to do it first it doesn't happen very often. i think i have been able to do it 3 or 4 times since june.
 
1 - 18 of 18 Posts
Top