Veloster Turbo Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
211 Posts
Discussion Starter · #1 ·
Hey guys,

Pretty sure I have a coolant leak at the head gasket. My coolant levels are dropping but it’s not leaking into the ground.

Anything else it could be?

Also, if this is the case I’ll be looking to replace bolts and the gasket. Do we have solid aftermarket options for these?

Lastly, how involved is a job like this to do myself?
 

·
Registered
Joined
·
454 Posts
Pretty involved.
Are you certain it’s at the head.
 

·
Administrator
2015 auto VT, 2013 manual VT × 2
Joined
·
5,784 Posts
Check plugs and see if any are wet. See if you have any misfires on cylinders via torque app by looking under test results.

Studs are available but not a diy project at all.
 

·
Registered
Joined
·
211 Posts
Discussion Starter · #4 ·
Pretty involved.
Are you certain it’s at the head.
Well that’s what I’m wondering. I don’t see any signs of oil in the coolant tank, no coolant foam on the oil cap.

That said, I don’t see any coolant hanging around the engine bay either. I’ll have to get it in the air to be sure but at a glance, nothing.

Here’s my can contents for reference:



 

·
Registered
Joined
·
211 Posts
Discussion Starter · #5 ·
Breather is top and left.

PCV bottom and right.

Lots in the breather, but I also tracked the car twice since emptying so maybe that’s the explanation.
 

·
Registered
Joined
·
454 Posts
Block test.
 

·
Registered
Joined
·
2,245 Posts
You can build a basic pressure test kit or buy one that uses an air compressor. Passenger floorboard isn't wet? Maybe get uv dye and flash light?
 

·
Registered
2013 Hyundai Veloster turbo automatic
Joined
·
3 Posts
Hey guys,

Pretty sure I have a coolant leak at the head gasket. My coolant levels are dropping but it’s not leaking into the ground.

Anything else it could be?

Also, if this is the case I’ll be looking to replace bolts and the gasket. Do we have solid aftermarket options for these?

Lastly, how involved is a job like this to do myself?
hey I know this is an older post but I am having this same issue right now and was curious if yours was a head or what you did to fix the leak? Thank you
 

·
Administrator
2015 auto VT, 2013 manual VT × 2
Joined
·
5,784 Posts
I believe he had a hg failure if memory serves me right. Search his posts and you may find something.
 
1 - 9 of 9 Posts
Top