Veloster Turbo Forum banner
1 - 20 of 24 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter · #1 ·
Hi.
My car is doing something weird. Everytime i floor it, my coolant overflow tank gets full and starts spilling out coolant. Normal temp via Torque App is from 80 to 89 celcius, if i floor it temp gets to 93 to 100 celcius. Yesterday it got to 110 celcius and the temp indicator in the cluster got two bars past medium. I bleeded the system about three times now and it continues happening. Maybe radiator cap? i don't know if the fact that i have a 2016 tucson engine has something to do with the problem. Anyone had this happening?
 

·
Administrator
2015 auto VT, 2013 manual VT × 2
Joined
·
6,315 Posts
Hi.
My car is doing something weird. Everytime i floor it, my coolant overflow tank gets full and starts spilling out coolant. Normal temp via Torque App is from 80 to 89 celcius, if i floor it temp gets to 93 to 100 celcius. Yesterday it got to 110 celcius and the temp indicator in the cluster got two bars past medium. I bleeded the system about three times now and it continues happening. Maybe radiator cap? i don't know if the fact that i have a 2016 tucson engine has something to do with the problem. Anyone had this happening?
Based on this post and others you have made, my vote is head gasket issue.

It is normal for ECT to go up, surge tank level to raise, with more power output. Not normal for it to overflow unless the tank is too full to begin with or it gets way too hot.

Provide more information on the current mods, tune, etc that's not oem, and what the temperatures get up to at stationary and low speeds vs highway speeds? This will help some.
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #3 ·
I really hope it's not HG issue. it started happening like one week after i replaced the radiator cap.
Mods: Sxth intake, NGK Laser iridium Spark plugs heat range 8, "sxth tune" (I don't know if it's real, i have been told that from the person i bought it from), Catch can on the breather side, 845MS FMIC, Secondary cat delete, muffler delete.
This is all as far as i can remember. Sometimes the car peaks at 1.8bar of boost, and sometimes at 1.5 bar, so it may be tuned for real?
 

·
Administrator
2015 auto VT, 2013 manual VT × 2
Joined
·
6,315 Posts
Oem tune on the car will be 1.2-1.4 bar max so if 1.5-1.8 bar boost then yes tuned.

Why was the radiator cap replaced and replaced with what? Any codes when scanning the car? What fuel octane do you use? Plugs are already not ideal for being tuned which means other things are likely not up to par either which other posts also suggested. Which is why I said could be HG issue. Possibe it is not but to get to those ECT numbers it does not happen easily with everything in working order.
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #5 ·
I replaced the cap because the one that came with the engine had the rubber seal broken, replaced it with a "Sankei" cap 1.1bar. No codes when scanning. I use premium gas (About 85 octane in my country) Mixed with 100 octane racing fuel, i normally mix 2 gallons of 100 octane with a full tank of premium, somethimes 4 gallons of 100 octane per tank. The plugs i think i saw it recommended in a post here. Didn't went with M45Xl because i want to try wmi with the heat range 8 first.
 

·
Administrator
2015 auto VT, 2013 manual VT × 2
Joined
·
6,315 Posts
What is the RON and MON of the fuel you use now? My guess is the octane may be too low for the tune and/or plugs are not correct for the tune or could be other reasons. What made the first engine pop?
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #7 ·
I dont know the RON and MON values of the fuel here. I had heat range 7 plugs before and the car will misifire like crazy with those plugs, now with heat range 9 everything is fine. The first engine blew up i think because of LSPI. The #4 rod blew up and made 4 holes into the block and oil pan, and broke the crankshaft. It blew up going from first to second at about 2k rpm.
 

·
Administrator
2015 auto VT, 2013 manual VT × 2
Joined
·
6,315 Posts
Your combo of mods, maintenance, fuel, and tune is leading to the same end result
 

·
Administrator
2015 auto VT, 2013 manual VT × 2
Joined
·
6,315 Posts
Means the mods, maintenance, fuel, and tune are not doing the engine any favors.
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #11 ·
Maintenance side, i do oil changes every 2500-3000 miles max with 10w40 sythetic with Motul or Liqui Molly oil. I bought the car with the mods it have now, minus the cat delete and the new engine. Fuel in my country is trash, that's why i mix the premium with the 100 octane so the car won't misfire. What do you recomend on doing?
 

·
Administrator
2015 auto VT, 2013 manual VT × 2
Joined
·
6,315 Posts
Proper mods, maintenance, tuning, and fuel you will have 0 issues. Take the steps to do these things better for better results. Prioity is seeing if that hg needs to be fixed first though or if it is something else.
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #13 ·
Got it, thanks. In case it needs a Head gasket replacement, do you think oem gasket and bolts will do it, or do i need ARP bolts and some other gasket?
 

·
Administrator
2015 auto VT, 2013 manual VT × 2
Joined
·
6,315 Posts
OEM head bolts are fine to a point but ARP studs are better if going for more power safely. OEM gasket will be fine.
 
  • Like
Reactions: CapBels

·
Registered
Joined
·
6 Posts
Hi.
My car is doing something weird. Everytime i floor it, my coolant overflow tank gets full and starts spilling out coolant. Normal temp via Torque App is from 80 to 89 celcius, if i floor it temp gets to 93 to 100 celcius. Yesterday it got to 110 celcius and the temp indicator in the cluster got two bars past medium. I bleeded the system about three times now and it continues happening. Maybe radiator cap? i don't know if the fact that i have a 2016 tucson engine has something to do with the problem. Anyone had this happening?
You have a faulty radiator cap. The increased pressure from the water pump when you floor it is causing it to fill the reservoir.
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #17 ·
Just replaced the radiator cap with a Gates 1.1 bar one. Went for a test drive and floored it a couple times. Temps raised to 96 celcius and couple minutes later droped to 84. Checked the resevoir and it is in its correct level. Seems like the old cap wasn't passing the coolant back to the radiator? I'll keep an eye on the resevoir for the next days and see what happens. Thanks!
 

·
Administrator
2015 auto VT, 2013 manual VT × 2
Joined
·
6,315 Posts
You need to top off the coolant and bleed it. Then check for hydrocarbons in the coolant with a test kit.
 

·
Super Moderator
2014 Veloster Turbo Manual
Joined
·
4,116 Posts
Like what kind of foam? Coolant will foam when it’s boiling. It’s like iced coffee when the HG is bad.
 
1 - 20 of 24 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top