Veloster Turbo Forum banner
1 - 16 of 16 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
Got my low beams installed. They work.

My fog lights, only one turns on.
I remember reading somewhere about using a relay but only hooking up one side?
I cant find the thread anymore.

Im about to order the harness. Hopefully someone can get me some info before i do.
 

·
Registered
Joined
·
90 Posts
Got my low beams installed. They work.

My fog lights, only one turns on.
I remember reading somewhere about using a relay but only hooking up one side?
I cant find the thread anymore.

Im about to order the harness. Hopefully someone can get me some info before i do.
You should use relay harness with HID for the fogs or you might ran into lights flickering issues. The relay increase the supply of stable power to your ballasts which helps in distributing the power to the HID lights directly from the battery.
 

·
Registered
Joined
·
340 Posts
No relay on Fogs

I have 35W HIDs on my fog lights without a relay harness. I was told it was not needed on the fogs because they are on a dedicated circuit. Mine work fine. See my photos below. You should check the electrical polarity at your power plugs.
I had to swap mine around and then they worked fine. I also have 55W HIDs for my low beams, but am using a relay harness there. Check those plugs before doing anything else.

ttwotees :cool2:

Land vehicle Vehicle Car Hyundai Hatchback Land vehicle Vehicle Car Hyundai Bumper
 

·
Registered
Joined
·
340 Posts
I have 35W HIDs on my fog lights without a relay harness. I was told it was not needed on the fogs because they are on a dedicated circuit. Mine work fine. See my photos below. You should check the electrical polarity at your power plugs.
I had to swap mine around and then they worked fine. I also have 55W HIDs for my low beams, but am using a relay harness there. Check those plugs before doing anything else.

ttwotees :cool2:

View attachment 969 View attachment 970
i had the same exact idea with red accents on the bottom except i have the ironman silver, what did you use for the red
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #7 ·
I have 35W HIDs on my fog lights without a relay harness. I was told it was not needed on the fogs because they are on a dedicated circuit. Mine work fine. See my photos below. You should check the electrical polarity at your power plugs.
I had to swap mine around and then they worked fine. I also have 55W HIDs for my low beams, but am using a relay harness there. Check those plugs before doing anything else.

ttwotees :cool2:

View attachment 969 View attachment 970

Do you have DDM fogs? Cause im also running 55w lows and 35w fogs. I tried flipping the connector around, all i get is one fog light on, and the other gets a very dim flicker
 

·
Registered
Joined
·
90 Posts
Do you have DDM fogs? Cause im also running 55w lows and 35w fogs. I tried flipping the connector around, all i get is one fog light on, and the other gets a very dim flicker
I'm using DDM's HID for my fogs, at first I tried it without a relay harness and one side doesn't light up at all.
 

·
Registered
Joined
·
340 Posts
I've had a relay harness on my fogs from day one.
Oh, I didn't say it wouldn't work tho. I just said you don't need a relay for the fogs. Mine works great without it. No flickering or other problem. The low beams however are a different matter.. You do need a relay for them.

ttwotees :cool2:
 

·
Registered
Joined
·
340 Posts
Do you have DDM fogs? Cause im also running 55w lows and 35w fogs. I tried flipping the connector around, all i get is one fog light on, and the other gets a very dim flicker
Are you in the U.S. ? Mine are not DDMs tho. Maybe thats the issue here. If you're getting dim flickers, then you must be getting some power. I would inquire of your supplier (DDM ?)


ttwotees :cool2:
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #12 ·
Ok thanks guys. I ordered the harness anyway assuming it was because the right fog light wasnt gettig enough juice to power up all the way.

Yes im in the US and i did use the relay harness for my low's since im using the 55w ballasts.

Does anyone know about hooking up the relay harness though?
Like i said, i remember reading something about there being an issue with hooking it up, like only one side could be hooked up or something really weird like that. I could be wrong and not remember the thread correctly.
 

·
Registered
Joined
·
90 Posts
Ok thanks guys. I ordered the harness anyway assuming it was because the right fog light wasnt gettig enough juice to power up all the way.

Yes im in the US and i did use the relay harness for my low's since im using the 55w ballasts.

Does anyone know about hooking up the relay harness though?
Like i said, i remember reading something about there being an issue with hooking it up, like only one side could be hooked up or something really weird like that. I could be wrong and not remember the thread correctly.
When you use a relay harness you only need to plug into one side of the stock bulb socket (driver side for me) and other other side (passenger side) will be only connected to the relay harness and not the stock bulb socket because both side will be power by the battery directly.
 

·
Registered
Joined
·
340 Posts
Ok thanks guys. I ordered the harness anyway assuming it was because the right fog light wasnt gettig enough juice to power up all the way.

Yes im in the US and i did use the relay harness for my low's since im using the 55w ballasts.

Does anyone know about hooking up the relay harness though?
Like i said, i remember reading something about there being an issue with hooking it up, like only one side could be hooked up or something really weird like that. I could be wrong and not remember the thread correctly.

This should help with the relay harness:

HID Kit Wire Relay Harness [Harness]

ttwotees :cool2:
 

·
Registered
Joined
·
340 Posts
I bought mine on ebay for $18.00 including shipping, but I also bought my HID kits from the same people.

ttwotees :cool2:
 
1 - 16 of 16 Posts
Top