Veloster Turbo Forum banner

1 - 20 of 21 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
My engine threw. A rod i was not driving hard at all when it occurred and my engine was judt getting to temp . Ive seen a few others with same milage needing new engine . Could it be malicious programing from hyundai? 2015r spec i took damn good car of my car and i did suspect i was having a coil pack starting to fail. No code thrown just rod . Tearing down withen the next few days to asses . Maybe with enough failure around same mileage we can prove hyundai is to blame
 

·
Registered
Joined
·
1,125 Posts
Oil used?
 

·
Registered
Joined
·
3,752 Posts
Good care of the car is relative and means little without maintenance details. Also how you drive the car and fuel used mods etc play a big role. On a 15 the tune is not as much of an issue as the older cars.

If it threw a rod then most likely has to do with oil used, filter used, oil change intervals, and how the car was driven on avg. Mediocre oil, filter, longer oil change intervals, driving the car hard, excessive G force cornering, cold starts, etc can all be detrimental.
 
  • Like
Reactions: misnblu

·
Super Moderator
Joined
·
3,265 Posts
i'm at 108K on my '14 :)

car is driven hard often, lots of track days, 5 complete seasons of autocross, oil changed meticulously between 3000-3500 miles with quaker state conventional (dealer changed) and hyundai filter. lots of cold starts with remote and idling lol... original coilpacks. some just have better luck than others and i'm sure mine will eventually run out.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #6
i used93 90%or 91never 87I changed my oil whenever it was dark and smelled like gas usually around 3000 mi maybe once did it go 3500,mi oil mobil 1 full syn . Suptec once (didnt have choice) filter was always oem cerma friction modifier at 20000mi. mods fmic .custom grill (grating ) , short ram intake ,exhaust was stock fuell line replace ment all coil pack repal ed ngk spark plugs and that it besides the 20 ft of el wire led everywhere and light bar o and big ass decal on sides (it made her go faster). I drove the hell out of it like YEAH . i was driving very conservatively when it blew i was stopped went to go and as soon as i put in third it went blah . Nothing spectacular just a bblah blah Dead. It was right around the time it was reaching operating tempature took oil pan off today in freezing rain
 

Attachments

·
Registered
Joined
·
1,125 Posts
Mobil 1 again for the kill!
 
  • Like
Reactions: Roadster

·
Registered
Joined
·
3,752 Posts
What specific M1 oil used? What FMIC? What intake? What NGK plugs and gaps? What coils? Also where do you live/where has the car spent its life for that 109k?
 

·
Registered
Joined
·
10 Posts
Discussion Starter #9
mobil 1Oil was annual full sulynthetic 5-20 fmic tork v1 ,ngk will look at later gaped to .28 car is in Missouri daily driver no signs of anything wrong it was using fuel i try and avoid and i rarely ever res lined it as it gives no more power i ususlly shifted before 5000when driving hard . And i was maticulas with oil changes i was trying to make this car last a long time. Why are replacments so expensive?
 

·
Registered
Joined
·
3,752 Posts
M1 is not only not a great oil for these engines in general but that's the wrong oil weight. With that weight oil it's like starting with 3k mile used oil and running it another 3k+ miles. That in itself amazes me it made it 109k before letting go. Get back on the plugs used and I hope you meant .028" and not .28" gaps. Also shifting before 5k hard driving is worse than going to redline as the fueling is worse and boost/load will be higher in the next gear making it harder on the engine. What coils were the OEM coils replaced with?

Replacements are not that expensive if you look in the right places and consider they'll last much longer with actual good maintenance. It's ok though as this is mostly examples of what not to do and likely due to poor research/knowledge on the platform. To answer if Hyundai is to blame here the answer is no, you're to blame, be it knowingly or unknowingly regarding the maintenance.
 

·
Registered
Joined
·
3,752 Posts
Starting with 5W20 when 5W40 is recommended then running it 3-3.5k+ miles to thin it out further is not good for the engine internals all else being the same. Oil analysis would back this up.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #13
My mistake it was 5-30oil i just looked for the blue one i stopped looking at weight loooong ago i did run 5-20in it around 20000miles but it was 5-30 mobile one extended ,gf-5
 

·
Registered
Joined
·
10 Posts
Discussion Starter #14
And duhhh im to blame for Everything in my life to believe otherwise is juvenile. I also put my car through a manic episode for o a year or so where i was umm shall we say "trying to die" or so i was told abbout my driving habbits. I can tell you it does the speed on the meter . I simply do not trust any mechanic( or any thing that walks talks or breathes ) except my brother in law and i had just seen a few others with same issue around same miles and i wouldn't put it past ANY car manufacturer to program a kill sequence if certain criteria weren't met ie. Dealer services $$that follow some kind of procedure or protocol so that the ecm knows and if you dont pay one way you will another way ie boomboom . Planned obselesnence its a modern plague! While we deplete our planets resources at higher rate than ever before instead of making things to last we design to fail so you must buy a new . Kinda off topic but i think you "smell the bacon im frying " .
 

·
Premium Member
Joined
·
1,966 Posts
There is no self-destruct logic in the ECM. If there was, it would’ve been discovered years ago.

However, your planned obsolescence conspiracy theory is mostly a matter of the OEM using cheap garbage parts and fluids, which is exactly why some of us longtimers promote overzealous maintenance with superior fluids and other techniques that protect against fundamental issues.

As you disassemble the engine, show us pictures of the intake valves as is.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #16
Affirmative on valves pic. I did use seafoam crc marvel mystery oil and straight wayer drip to clean im itresrested myself
 

·
Registered
Joined
·
5 Posts
Hey looks like you fell victim to the first gen issue. Weak internals. There is only one real fix. Upgrade your piston arms. This issue is inherent in all 2013-2015 turbos. Many tuners won't touch your car with out replacing your rods because the factory rods are made of glass. The last recall on our first gen vt"s was to drop the boost from 20psi to max 18psi trying to save our engines from their engineering oversite. Sorry for the bad news.
 

·
Registered
Joined
·
3,752 Posts
Yes he has a 13
 
1 - 20 of 21 Posts
Top