Veloster Turbo Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
I was merging onto the highway and gave it full throttle. The car started lurching and rpms bounced. I got a flashing CEL right then and the car lost pretty much all power. The idle is horrible. I just installed a tune less than a month ago, and I suspect that may have been the cause of this. I just pulled the spark plugs and they look fine. As for the coil packs I haven't tested them yet, just figured I would ask around here real quick. I have an oil catch can, HKS spark plugs, 5w40 full synthetic Mobil 1 oil, aftermarket boost solenoid, K&N cold air intake, intercooler resonator delete, and stainless steel fuel line. Any ideas on this? If anyone has had similar problems I would appreciate some advice. Thanks!
 

·
Super Moderator
Joined
·
3,710 Posts
any codes?
 

·
Super Moderator
Joined
·
3,710 Posts
yeah i just saw that... who tuned ya? are you able to make any logs?
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #5 ·
Currently don't have a way to log unfortunately. I just have this cheap little code reader. As for the tune I ordered it from LAP3.
 

·
Super Moderator
2015 auto VT, 2013 manual VT × 2
Joined
·
5,233 Posts
So you got an off the shelf tune after asking why people advise against some tunes, then you buy the most expensive off the shelf tune thats not advised or great anyway, and you do this without having all mods to make said tune safe as possible? Were you even running 93 octane fuel? Do you have an older and/or higher mileage VT?

Hopefully the engine is ok and can easily be fixed whatever the issue is and you get a decent tune for the car from here on out. Need to check compression, leakdown, plugs be sure in good shape, gap to .024", 93 octane fuel, and really water/meth to run that tune remotely safely.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #7 ·
So you got an off the shelf tune after asking why people advise against some tunes, then you buy the most expensive off the shelf tune thats not advised or great anyway, and you do this without having all mods to make said tune safe as possible? Were you even running 93 octane fuel? Do you have an older and/or higher mileage VT?

Hopefully the engine is ok and can easily be fixed whatever the issue is and you get a decent tune for the car from here on out. Need to check compression, leakdown, plugs be sure in good shape, gap to .024", 93 octane fuel, and really water/meth to run that tune remotely safely.

I know this is a really old thread now, but I finally got it into the dealership and had someone take a look at it. They had a hard time figuring out what was going on with it. Turns out it was one of the coil packs and said that the connectors that go to the coil packs were not seating properly. They replaced the coil pack that went bad and it seems to run great now. That being said I think at this point I will highly consider getting a custom tune done rather than running this off the shelf tune. I was running 93+ octane and I have about 50k miles on the car. I will definitely be looking into a water/meth injection kit as well. Thanks for the replies.
 
1 - 7 of 7 Posts
Top