Veloster Turbo Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1 (Edited)
I have been experiencing a squeak mostly when accelerating from a stop but also slightly little when braking. It doesn’t matter how fast I accelerate I still get the same noise but the pitch of the noise raises as it reaches the end of its travel. Also when I let off the gas and the car downshifts I feel the front passenger tire pull to the right and just recently noticed it pull slightly left when quickly accelerating. Most of the time there is a clunk associated with the downshifting pull. I have changed the CV axel on the passenger side both front lower ball joints and by recommendation I had it aligned and tires rotated and balanced prior to changing either of those. Everything is stock!! Not sure where to go from here but I’m not made of money and I can’t just keep throwing money at it although I gladly would if it were in my cards. Please any help would be greatly appreciated. I have been driving a loaner for a little over a month so as not to make the problem worse so if you have any questions about details I will be following this thread closely!! Thank you in advance!!

‘14 Veloster Turbo 106k miles
Never had to do any work to it until now.
 

·
Registered
Joined
·
23 Posts
That sucks man. Best thing you could do would be to get it on video. That might make things easier for someone to help diagnose. Definitely hope you get it resolved. Especially in case mine ever does it.
 
1 - 2 of 2 Posts
Top