Veloster Turbo Forum banner

who all that has installed hid's with a relay have had problems with them

1 - 13 of 13 Posts

·
Registered
Joined
·
375 Posts
Discussion Starter · #1 ·
ok this is for all that have installed hid's. i have had my hid's for a while but have been waiting to install them till i got my intake in so i only had to remove the bumper once. how many of you that have installed them have had problems with them. i have been debating on installling them since i have seen so many people posting problems. for example radio interfernce, tpms interference, flickering, turning off. etc etc. i am only interested in people that have installed them with the relay.
 

·
Registered
Joined
·
148 Posts
I installed mine with the relay and have the radio interference problem. It's annoying.
 

·
Moderator
Joined
·
2,385 Posts
I installed both lows and fogs and only have the buzzing noise under the hood. That is all, no major issues.
 

·
Registered
Joined
·
344 Posts
I have only low beam HIDs from Diode Dynamics. I OCCASIONALLY get a relay buzzing due to the pulse width modulation. Most of the time, they work fine. Even after buzzing for a while, they seem to stop by themselves. Last I heard, Diode was working on a fix but that was a few weeks ago and nothing yet. The light pattern also jiggles a bit when going over hard bumps.
 

·
Registered
Joined
·
375 Posts
Discussion Starter · #6 ·
thanks but its not the help im worried about. i dont feel like installing them to have all these issuses that alot of people seem to be having. just trying to get a general idea of how many people are having these issues
 

·
Vendor
Joined
·
3,541 Posts
i haven't had any issues with my low HIDs at all, just had some weird issues with the fogs.
 

·
Registered
Joined
·
353 Posts
I have the Diode Dynamics low beams, and fogs with relays.
No buzzing, no interference, no flickering. Pretty much perfect for me.

I don't have TPMS though, so I can't comment on that.
 

·
Registered
Joined
·
375 Posts
Discussion Starter · #9 ·
bump. seems like a lot of hid owners havent voted yet. still debating on installing them but probably will anyways.
 

·
Registered
Joined
·
90 Posts
I had a few problems (buzzing, flickering, shutoff, overheating ballast) from my previous HID kit brand.

After swapping my kit to Morimoto HID kit with heavy duty relay harness, I didn't have any problems yet.
 

·
Registered
Joined
·
39 Posts
I had a few problems (buzzing, flickering, shutoff, overheating ballast) from my previous HID kit brand.

After swapping my kit to Morimoto HID kit with heavy duty relay harness, I didn't have any problems yet.
I'm considering going the same route, but using their "CANbus" harness instead. I looked on TheRetrofitSource's website and they don't list H11B, but I assume H11 kit works? Their CANbus harness supposedly comes with a massive capacitor that should cancel out the PWM?
 

·
Registered
Joined
·
177 Posts
I had some issues installing the fog lights... Not sure if i burned out the relay switch or the capacitor I put on (to help with the buzzing issue). Going to try and install again, considering getting a new relay (http://www.autozone.com/autozone/parts/_/N-8vdxg?itemIdentifier=44799_0_0_) Not sure if I should continue with the one that started smoking.... Probably not.
 

·
Registered
Joined
·
1,193 Posts
hey guys i wondering cause imma be getting the Morimoto low beam HIDS since the ballast actually helps on avoiding the TPMS error but lets say for the fogs i go ahead and get a DD or DDM would i end up seeing that issue still ? or should i just live witht eh TPMS light lmao
 
1 - 13 of 13 Posts
Top