Veloster Turbo Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
76 Posts
Discussion Starter #1
:crazy: Random oil check about 500 miles post oil change; Disaster on the dip stick!! I hate it when my dip stick comes out with debris all over it! Seriously though, oil looked like water, way over full with foreign material on the lower curled portion of the stick. One sniff confirmed my worse fear; fuel in the oil.... I did not confirm whether or not the debris was metal, but, it wasn't soft.

Pretty heart breaking but I thought I should share with you guys just in case the problem arises in someone elses car. I did not take pictures of the oil or debris.
After having it towed into the dealer 35 miles away, they called me a few hours later to let me know it is A high Pressure fuel pump failure. Leaking into the cylinders and down into the oil. Three days for the pump to come in, everything covered under warranty including the tow.

I picked up their proffered loaner today and addressed the Debris and asked them to check for metal shavings. The adviser said if they find them they will do what they can to have the engine replaced. I would be cool with that but if they dont then I will trade out before the 60k is up. Running fuel for oil even for 500 miles will eventually lead to engine failure IMHO.
IMG_20150415_101857156_HDR.jpg

Check out what they gave me though. IMG_20150416_121729995_HDR.jpg IMG_20150416_121748654_HDR.jpg
 

·
Registered
Joined
·
76 Posts
Discussion Starter #3
dang man, that suck. Hopefully they find the debris and get you a new engine. Enjoy that loaner. Those things are fast
Thanks Matty,
the sonata is pretty cool for a sedan.
 

·
Banned
Joined
·
550 Posts
Dang that sucks, I would push for the engine to be replaced, even though we have an oil filter and pickup screen the debris and fuel would have had to make it all the way back down through the head from the cam lobe. There is bound to be damage. How many miles do you have and did anything lead up to this. This is the first HPFP failure I remember seeing.
 

·
Registered
Joined
·
76 Posts
Discussion Starter #5
Dang that sucks, I would push for the engine to be replaced, even though we have an oil filter and pickup screen the debris and fuel would have had to make it all the way back down through the head from the cam lobe. There is bound to be damage. How many miles do you have and did anything lead up to this. This is the first HPFP failure I remember seeing.
24000 miles. I agree, new engine and ODO set to zero! Nothing led up to me checking the oil that day. A few weeks back I did have the fuel line replaced fore to aft because it was collapsing under WOT. That was covered under the warranty. Then just had the oil changed a week after the fuel line was done.
 

·
Banned
Joined
·
550 Posts
24000 miles. I agree, new engine and ODO set to zero! Nothing led up to me checking the oil that day. A few weeks back I did have the fuel line replaced fore to aft because it was collapsing under WOT. That was covered under the warranty. Then just had the oil changed a week after the fuel line was done.
Thats crazy, I really hope everything goes well. They can't though set the ODO to 0 as the body still has 24k on it.
 

·
Registered
Joined
·
59 Posts
You also wouldn't want your oil pump to suck in the debry, possibly cause it to fail? If so, there go your bearings.
 
  • Like
Reactions: klingon
1 - 10 of 10 Posts
Top