Veloster Turbo Forum banner
1 - 20 of 49 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter · #1 ·
Hello out there.

I have owned my VT since they first came out and have 88K kms on the clock.

Since January this year I've been reporting to my dealer that my engine is misfiring in 3rd gear (its a manual) at 3000 rpm.

I could also at times during the misfiring head a tapping / clicking sound from the engine bay.

The dealer (once I received the engine warning ilght) did find that the spark plugs had cracked and that the turbo waste gate was not working / opening.

They replaced the spark plugs and i got a full turbo unit replaced, and additionally knock sensors were replaced too as a precaution.

I was due to return the car to the dealer this week as the misfiring had not been solved, however the car blew its engine over the weekend and was towed to them.

For a moment, my car had afterburners - as I saw orange flames shoot out the exhaust; the hatch is covered in oil stains.

The engine dropped all of its oil once I rolled to a stop and a chunk of what looks like the engine casing was found under the car.

Fortunately I have warranty covering me, the iCare system and my dealer are making sure I'm looked after well - which is more than I can say for experience with other brands I have owned.

This is being described by the dealer as a rare problem, and I cannot find any content online matching the problem, so it should serve as warning if you do begin to experience misfiring that cannot be resolved.

Awaiting more info from the dealer - hoping that this is an isolated problem.
 

·
Registered
Joined
·
1,116 Posts
I think the engines blowing up has been reported on here quite a few times and is a common problem with the early models.
 
  • Like
Reactions: didisinned

·
Registered
Joined
·
10 Posts
'13 VT, I had a sparkplug failure last summer, at the time I was using 87 octane and whatever oil the dealer had (5w30), they replaced the sparkplug and everything seemed to work well at that point.
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #16 ·
I have used 95 and 98 RON, but mostly 95 RON

99% of the time my refuel is from BP, but if stuck, would use Shell

The servicing interval is the manufacturer's service interval, not my own choice.

I can get the Engine details later tonight from my service dockets, as sourcing it from the car is not possible (its in the workshop)

I'm pretty sure Castrol oil is used, the specifics - again I need to look at the service dockets
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #19 ·
So you let the dealer change the oil at 7500km, which for us yanks is 4,660 miles. Do you know what brand, product and grade of oil they filled with?

What RON fuel do you use?

Please post your engine ID. It's on a label/sticker affixed to the top/back of the valve cover (remove plastic engine cover first).
The oil used is 5W-30 from my service receipt - pretty sure its Castrol, but not stated on the docket.

Engine Number is: G4FJCS409009
 
1 - 20 of 49 Posts
Top