Veloster Turbo Forum banner
1 - 19 of 19 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
My veloster turbo has steering wheel warning light, air bag light, emergency brake light, traction control light, ABS light, check engine light on.... The gauges keep dropping to 0..... it's an automatic, and it won't shift out of park and the square on the dash where it tells you what gear your in (park "P") is blank. I was able to release the shifter by pressing the shift lock and got it to the dealership.
Anyone ever experience this many problems at once?
 

Attachments

·
Super Moderator
Joined
·
3,826 Posts
Do you have anything plugged into the ODB port.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Old port? Nothing is plugged in.
Just got a call from the dealer saying that we need a new vacuum pump! Not sure how a vacuum pump can cause the dash board to light up like a Christmas tree!
 

·
Registered
Joined
·
1,100 Posts
I think RPW meant the OBD / diagnostic port. Sometimes leaving a scan tool / logging device plugged in can make the computer freak out. My guess was going to be a communications/electrical/wiring issue, or perhaps a bad ground somewhere. No very specific, but certainly wouldn't have thought of the vacuum pump. No idea how that could be related. Oh well, if they want to tinker under warranty, no complaints. Best of luck!
 

·
Super Moderator
Joined
·
3,826 Posts
thanks geek, that is what i meant...
 
  • Like
Reactions: geekdragon

·
Registered
Joined
·
3 Posts
Discussion Starter · #6 ·
I wouldn't think a vacuum pump would cause these problems either. The car seemed to drive fine ..... other than not being able to get it outta park!
Dealership said that the pump had to be ordered and said could be 1day to 2weeks!! Then they can start doing more diagnostics! FML
 

·
Registered
Joined
·
1,246 Posts
This has happened to me when my bro's big hands went looking for a lighter that fell under the passenger front seat. all my shit went wild on my dash and i could drive anywhere or shift or do anything for about 10 mins in a parking lot. since then everything has been normal. I highly doubt them replacing the pump fixed anything other than getting a new pump :)
 

·
Registered
Joined
·
1 Posts
My veloster turbo has steering wheel warning light, air bag light, emergency brake light, traction control light, ABS light, check engine light on.... The gauges keep dropping to 0..... it's an automatic, and it won't shift out of park and the square on the dash where it tells you what gear your in (park "P") is blank. I was able to release the shifter by pressing the shift lock and got it to the dealership.
Anyone ever experience this many problems at once?
Hello Im Having the Same Exact Problem did you ever Figure it Out?
 

·
Registered
Joined
·
5 Posts
My veloster turbo has steering wheel warning light, air bag light, emergency brake light, traction control light, ABS light, check engine light on.... The gauges keep dropping to 0..... it's an automatic, and it won't shift out of park and the square on the dash where it tells you what gear your in (park "P") is blank. I was able to release the shifter by pressing the shift lock and got it to the dealership.
Anyone ever experience this many problems at once?
I have exact problem- did you ever figure it out?
 

·
Administrator
2015 auto VT, 2013 manual VT × 2
Joined
·
5,564 Posts
I've seen this before and it's usually related to the vacuum pump, clockspring, or the battery.
 

·
Registered
Joined
·
5 Posts
I wouldn't think a vacuum pump would cause these problems either. The car seemed to drive fine ..... other than not being able to get it outta park!
Dealership said that the pump had to be ordered and said could be 1day to 2weeks!! Then they can start doing more diagnostics! FML
My veloster turbo has steering wheel warning light, air bag light, emergency brake light, traction control light, ABS light, check engine light on.... The gauges keep dropping to 0..... it's an automatic, and it won't shift out of park and the square on the dash where it tells you what gear your in (park "P") is blank. I was able to release the shifter by pressing the shift lock and got it to the dealership.
Anyone ever experience this many problems at once?
Dealership just told me the same thing and would cost 1098.00. Is the vacuum pump the cause to all the warning lights? If so what is the replacement part number?
I've seen this before and it's usually related to the vacuum pump, clockspring, or the battery.
My veloster turbo has steering wheel warning light, air bag light, emergency brake light, traction control light, ABS light, check engine light on.... The gauges keep dropping to 0..... it's an automatic, and it won't shift out of park and the square on the dash where it tells you what gear your in (park "P") is blank. I was able to release the shifter by pressing the shift lock and got it to the dealership.
Anyone ever experience this many problems at once?
 

·
Registered
Joined
·
5 Posts
Did vacuum pump fix your problem? My VT has this same issue. Where is a good place to find replacement part.
 

·
Registered
Joined
·
5 Posts
Yes the vacuum pump solved the problem. Same exact sympoms: speedo dropout, all sorts of warning lights, but car ran fine. The issue is that the vacuum pump, which is on the CAN bus, basically shorts out the bus blocking communication between about 7 different modules. Also, unfortunately, this tends to damage the airbag module. So after replacing the pump, if the airbag light remains on, you'll probably need airbag module. Don't change airbag module first- it will just get damaged again.

Used vacuum pump, as well as used airbag modules can be found on eBay. I paid my local mechanic $500 total (that included parts and labor), he got the parts off eBay.
 

·
Registered
Joined
·
5 Posts
Also, you can unplug the pump- most of the warning lights should go out. Speedo should work normal again. If your airbag light goes out you are lucky, and leave the pump unplugged. Be careful brake pedal will be very hard to press- you basically won't have power brakes. I don't recommend driving with pump unplugged.
 

·
Registered
Joined
·
5 Posts
You nailed the second problem with airbag light. Can't thank you enough, I should have joined this forum before taking to dealer. I told them I'd pay the 89 dollar fee for locating the problems but I'd fix myself.
 

·
Administrator
2015 auto VT, 2013 manual VT × 2
Joined
·
5,564 Posts
Albert Hwang on FB for the parts
 

·
Registered
Joined
·
1 Posts
Did the a/c also lose cooling function? Mine will turn on but the air never gets cold. I also have all of the same lights on the dash. The ecu module has already been replaced and didn't fix the issue.
 
1 - 19 of 19 Posts
Top