Veloster Turbo Forum banner

1 - 20 of 26 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
My 2014 Veloster keeps misfiring on the 4th coil I replaced the coil and it drove just fine for about 20 miles, then did the same thing, could it be anything else?
 

·
Registered
Joined
·
1,166 Posts
Oem coils?

When was the last time you changed spark plugs?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
I just changed the spark plugs yesterday, and no the coil was from Napa auto parts :(
 

·
Registered
Joined
·
1,166 Posts
All coils replaced?

What spark plugs?

I would recommend only utilizing OEM coils, even if tuned.
 

·
Registered
Joined
·
700 Posts
Swap the coil 4 and coil 3 (or any other) and see if the misfires follows. If it follows you got issue with the new coil. If it stays - it’s something else.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
No just the 4th coil was acting up, and the spark plugs are auto light XP iridium, so do you think I should buy a new Hyundai coil? Will it go out again?

All coils replaced?

What spark plugs?

I would recommend only utilizing OEM coils, even if tuned.
 

·
Super Moderator
Joined
·
1,121 Posts
I also recommend OEM plugs and coil pack. Properly gap the plugs also
 

·
Registered
2015 auto VT, 2013 manual VT × 2
Joined
·
4,260 Posts
Issue is crap plugs and crap coils. Replace with new oem coils part number ending in 2B110 and if you're remaining on the oem tune then get new oem plugs from the 19+ VT and gap to .028". If tuning the car go with HKS M45XL plugs and gap to .024". If you need a good price on the plugs and coils let me know.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #9
Issue is crap plugs and crap coils. Replace with new oem coils part number ending in 2B110 and if you're remaining on the oem tune then get new oem plugs from the 19+ VT and gap to .028". If tuning the car go with HKS M45XL plugs and gap to .024". If you need a good price on the plugs and coils let me know.
Yes I need a good price on the oem coils please? and thank you
 

·
Registered
2015 auto VT, 2013 manual VT × 2
Joined
·
4,260 Posts
Albert Hwang on FB otherwise I can get them for you.
 

·
Registered
2015 auto VT, 2013 manual VT × 2
Joined
·
4,260 Posts
A coil will not be the solution here based on how the coils and the ecu operates. Also if you order a coil it will cost like $70 vs $200/4 coils. Get better plugs as well. Heat range 8 only for the oem tune and gap all to .028".
 

·
Registered
Joined
·
2 Posts
Issue is crap plugs and crap coils. Replace with new oem coils part number ending in 2B110 and if you're remaining on the oem tune then get new oem plugs from the 19+ VT and gap to .028". If tuning the car go with HKS M45XL plugs and gap to .024". If you need a good price on the plugs and coils let me know.
I do!
 

·
Registered
Joined
·
6 Posts
I did everything you guys said I swapped the coil and spark plugs to eom and it’s still doing the same thing I don’t know what to do
 

·
Registered
2015 auto VT, 2013 manual VT × 2
Joined
·
4,260 Posts
If you did everything I suggested then the issue will most likely be tune or fueling related. However I was born at night but not last night and know that you did not do that.

Hard to help when you do not follow suggestions to fix properly and you give so little details to start with on the car and the issue at hand.

Trying to take the cheap way out will usually cost you more in the end.....
 

·
Registered
Joined
·
6 Posts
If you did everything I suggested then the issue will most likely be tune or fueling related. However I was born at night but not last night and know that you did not do that.

Hard to help when you do not follow suggestions to fix properly and you give so little details to start with on the car and the issue at hand.

Trying to take the cheap way out will usually cost you more in the end.....
I literally just swapped out the parts for oem quality how is that taking the cheap way out I’m confused? Also I’m not here to argue I just need some help and suggestions
 

·
Registered
2015 auto VT, 2013 manual VT × 2
Joined
·
4,260 Posts
I'm not arguing either I'm trying to help.

In reference to post #8 did you do what I told you to do so far or not? Your posts and my educated guess says no.

If the answer is no then this is why you're trying to be cheap to properly fix the issue.
 

·
Registered
Joined
·
1,166 Posts
Post pics of the part #'s & gap of the spark plugs
 

·
Registered
Joined
·
6 Posts
I'm not arguing either I'm trying to help.

In reference to post #8 did you do what I told you to do so far or not? Your posts and my educated guess says no.

If the answer is no then this is why you're trying to be cheap to properly fix the issue.
okay mr educated guess man, since you just know the answer to everything, can you tell me why it’s still misfiring even after I did what you said in post #8 I changed the spark plugs to oem and the ignition coils to oem, oh and by the way it gapped to 28. it’s a stock 1.6 tune. it’s turbocharged. it’s a manual, I’m the second owner but it doesn’t look like they did any mods to it. Does that help.
 
1 - 20 of 26 Posts
Top