Veloster Turbo Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I just purchased a 2015 VT and I'm having some peculiar behavior with the radio. When I plug my ipod or phone in via usb the music plays fine however when i turn the car off and back on it starts playing the very first song on the ipod. This happens every time and it's pushing me to the point of replacing the radio. I've seen some people say that turning off Gracenote fixed the issue for them. Tried that and it doesn't help me. I took it to the dealership this morning and the smart service people gave me a "free" Hyundai Ipod cable and said try that. Only issue with that is I have to control my music from the Ipod and not the radio. Has anyone successfully come up with a fix for this or am I just screwed?
 

·
Registered
Joined
·
116 Posts
I just purchased a 2015 VT and I'm having some peculiar behavior with the radio. When I plug my ipod or phone in via usb the music plays fine however when i turn the car off and back on it starts playing the very first song on the ipod. This happens every time and it's pushing me to the point of replacing the radio. I've seen some people say that turning off Gracenote fixed the issue for them. Tried that and it doesn't help me. I took it to the dealership this morning and the smart service people gave me a "free" Hyundai Ipod cable and said try that. Only issue with that is I have to control my music from the Ipod and not the radio. Has anyone successfully come up with a fix for this or am I just screwed?
This is by design.. have many friends with all different manufactures does the SAME thing, it's only iPhone, not Android.. but it seems like the Radio wants to play music by default.. go figure.
 

·
Registered
Joined
·
1,192 Posts
To me this makes sense and seems normal. I don't think the head unit's internal memory keeps track of last song played or playlists etc... Its like turning the power off any home stereo or speaker, it typically won't remember what you last played.
 

·
Registered
Joined
·
618 Posts
I just purchased a 2015 VT and I'm having some peculiar behavior with the radio. When I plug my ipod or phone in via usb the music plays fine however when i turn the car off and back on it starts playing the very first song on the ipod. This happens every time and it's pushing me to the point of replacing the radio. I've seen some people say that turning off Gracenote fixed the issue for them. Tried that and it doesn't help me. I took it to the dealership this morning and the smart service people gave me a "free" Hyundai Ipod cable and said try that. Only issue with that is I have to control my music from the Ipod and not the radio. Has anyone successfully come up with a fix for this or am I just screwed?
This is an old bug that has been around since the 2012's ... There is a file on the iPod that keeps track of the currently playing song. The head unit uses that file to restart playback when you restart the car. When this file gets corrupted the head unit can't resume playback properly. The fix is to delete the file and then reattach the iPod to the car.

Yes the car will remember the position in the currently playing song on the iPod...

Problem is I can't remember where that file is located or how to delete it... But this is documented on this forum or on the other non turbo Veloster forum...

Sent from my Nexus 5 using Tapatalk
 
1 - 5 of 5 Posts
Top