Veloster Turbo Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter #1
Hey guys

Just as spring arrived my CEL also has appeared on my 2014 veloster turbo.

The code says bank 1 sensor 1 so i believe an upstream o2 sensor is what i need.

Im browsing this site which populates oxygen sensors and fuel to air sensors. Now my question is, are they both referring to the same part?

Link:

Im also thinking of soaking the sensor in some water or vinegar and see if the it fixes the issue.

I had this part changed a few years ago. the mechanic said my sensor burnt out or something but im not sure which sensor he switched out. He said it could be the set up i have. Ive added an adapter pipe to attached an cone filter.

If someone can confirm this part can replace the current one, it would be much appreciated.
 

·
Super Moderator
2015 auto VT, 2013 manual VT × 2
Joined
·
4,805 Posts
Albert Hwang on FB
 

·
Registered
Joined
·
34 Posts
Discussion Starter #3
Albert Hwang on FB
I tried looking for him on fb but dont know which is him. Also, im in Canada so would getting parts from him be more expensive or difficult?

I saw on another post theres 2 part numbers for the o2 sensor: 39210-2B250 OR 39210-2B210.

Is there any difference?
 

·
Registered
Joined
·
91 Posts
I tried looking for him on fb but dont know which is him. Also, im in Canada so would getting parts from him be more expensive or difficult?

I saw on another post theres 2 part numbers for the o2 sensor: 39210-2B250 OR 39210-2B210.

Is there any difference?
Albert Hwang Should be no difference and if so very minuscule parts are shipped straight out of South Korean usually DHL.
 

·
Registered
Joined
·
34 Posts
Discussion Starter #5
Thanks. Btw is there a reason why most members recommend Albert Hwang for parts?
 
1 - 6 of 6 Posts
Top