Veloster Turbo Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1 (Edited)
Hey guys, I'll do a more thorough forum search when I get home or I'm at work and thought I'd throw this up in the meantime.

2013 Veloster, drove fine when I got it a week ago, threw on an Injen intake and seemed fine, put a 3" solo catless dp on at lunch today and during the test drive it seems to start to pull hard around 4000-4500 and then just hits a wall, like the throttle motor isnt even attached to the pedal. No codes (other than P0420 of course).

Ideas? Extra boost pushing open a half failed BPV? Bad boost solenoid? New 2013 recalled software? Just seems strange than an exhaust mod of all things seems to have caused it.

Updated info: Definitley seems to me to be boost related. If I keep it in 2nd or 3rd and simply accelerate at half throttle it will roll up above 6,000 rpm freely. if I romp on it I hear what seems to be a chattering noise from the intake.
 

·
Registered
2013 VT, Manual
Joined
·
67 Posts
Sounds like a familiar problem I've read on here before. I would read up on previous posts.
 

·
Registered
Joined
·
2,957 Posts
If no other codes then most likely fuel line issue.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #4
Sorry guys, I have read and it definitely seems like the fuel line issue. Why immediately after the DP though? I'd love to say it added so much power the oem mount just couldnt handle it, but thata a bit dreamy of me.

However, I am going in today to pull the intake off and give it a carbon scrub, I'll take a peek at the lines and maybe a braided line is in my future.
 

·
Registered
Joined
·
62 Posts
Now that you got your probably potentially identified, how did you install a downpipe over lunch? I would have thought it would take much longer than that.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #6
To be fair mostly because I'm what you would call a...is it ASE Master Tech? That time even included a bunch of torch work because I live in the rustiest place on planet earth.
 

·
Registered
Joined
·
2,957 Posts
Also keep in mind that the solo dp is just a lower dp and not a full elbow so the install is much easier to do.

It added just enough power, fuel flow, and flex in the car to cause the already bad OEM line to show issues.

I've seen some have no issues after a better lower engine mount bushing was installed. You'll need that anyway to help prevent wheel hop and engine movements. May be a cheaper fix for now than doing a fuel line. You'll likely need both eventually if you plan to mods further.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #9
I'm still confused at the BPV chattering starting at 3500 rpm or so though. Is that just a natural byproduct of the car trying to ditch boost because it's not hitting the target AFR due to lack of fuel?
 

·
Registered
Joined
·
2,957 Posts
It does what it has to per the tune in the car to meet commands.
 
1 - 10 of 10 Posts
Top