Veloster Turbo Forum banner

41 - 47 of 47 Posts

·
Super Moderator
Joined
·
1,966 Posts
Discussion Starter #41
“Shuttering” is not LSPI. If you encounter true LSPI, you will have a nice hole in your block where one (or more) component ejects from the super/megaknock.

If your ignition coils are over 40,000 miles old, replace them all.

Get the recall done.
 

·
Registered
Joined
·
741 Posts
Thanks for the reply.

The plugs are new with only 15,000 miles on them and I have replaced the coil pack Cylinder #3 after I got a code for a miss fire on that cylinder. Since then I have the shutter intermittently and computer shows no codes.
I had shuttering but no codes. It turned out to be a coil pack, forgot which cylinder. 2 weeks earlier Hyundai replaced a bad spark plug, but shuttering didn't go away until after the coil pack was replaced.
 

·
Registered
Joined
·
65 Posts
I had the recall done, along with the evap canister...and I can tell you that this feels like a new vehicle. I have a 2013, and it shifts so much more responsively, less shift lag, and generally feels excellent to drive. And thats on regular octane! I have no mods other than suspension, and its an automatic.
 

·
Registered
Joined
·
2 Posts
You guys were taking on the recall of the 2013 veloster. Well Ihave been threw hell with mine. Two new lower ends block in all. And re did the heads. It all started around 50k milea when it started to eat spark plugs
And I mean eat them. It would burn the Center of the plug completely out.thwy could never figure it out until we did. And it all summed up to the recall. Pre igniting Cylinders. I guess they would get so hot that it would burn the motor down. So for 40k mile two motors later. (All under warranty) and the last motor they covered with 101k miles on the car. I just got it back after 4 months. Seems to be running great. But then again it only has 3k milea on it.
 

·
Registered
Joined
·
2,957 Posts
OEM coils with age on them, OEM plugs, OEM fuel line, OEM tune, and low octane fuels all kill the 13's.
 

·
Registered
2013 VT, Manual
Joined
·
67 Posts
Make sure they replaced those ignition coils. I wouldn't be surprised if you have the same coils after two engines replacements.
 
41 - 47 of 47 Posts
Top