Veloster Turbo Forum banner

21 - 28 of 28 Posts

·
Registered
Joined
·
9 Posts
What tune is in it? What fuel do you use? Mods on the car? Year and transmission?
I need to find out exactly which tune my garage put on it. Hah. Will get back to you on that.
2016 turbo w/6spd man trans. Been using premium gas. K&N Cold air intake and aftermarket blow off valve, which I believe is an HKS (need to double check that). Had nearly 88K when I bought it last month.
 

·
Registered
2015 auto VT, 2013 manual VT × 2
Joined
·
4,014 Posts
What shop tuned it?
 

·
Registered
2015 auto VT, 2013 manual VT × 2
Joined
·
4,014 Posts
I've heard of Alphaspeed but not speed tuning. Unless the shop is speed tuning and they're using HP tuners.
 

·
Registered
2015 auto VT, 2013 manual VT × 2
Joined
·
4,014 Posts
I got the OP sorted on his issue. Was coils causing the issues but needed plugs as well.

TS Axle sounds like you bought a used VT that you have no idea of the mods or tune on it. That's not a good thing to be trouble free. Many things can cause the symptoms you have.
 

·
Registered
Joined
·
9 Posts
I got the OP sorted on his issue. Was coils causing the issues but needed plugs as well.

TS Axle sounds like you bought a used VT that you have no idea of the mods or tune on it. That's not a good thing to be trouble free. Many things can cause the symptoms you have.
No, for the most part the car is fine. I'm the one who paid for the tune! hahaha. I may be overstating the issue with the...rhythm of the engine under load. Actually, it reminds me of my old 944 when it accelerates. I'm curious about the mpg that I'm getting so far. But I only replaced the plugs, not the coils. I'm going to swap out the coils when I have new wheels put on in the next week or so. I'll check back in with an update after that. Thanks very much for the help so far.
 
21 - 28 of 28 Posts
Top