Veloster Turbo Forum banner

41 - 58 of 58 Posts

Registered
Joined
44 Posts
Discussion Starter #41
Looks good and love the shaved cover but I'm curious why you didn't shave the rear 2 pieces too? 馃え
Now I can copy you with a shaved cover and does clean up the bay quite nicely. 馃榿Looks less cluttered. 馃憤
Unofficially?
My cut off wheel/disc broke.
I ran out of break time at work(can't do personal stuff while on the clock).
Unofficially?
I was lazy lol




Here's the finished product.
Combined with tidied up wiring from the wire tuck, I'm quite happy.
Now to do something with that intake manifold.
105054
105055

105056
105057





Now just to get those lowering springs on!
 

Registered
Joined
44 Posts
Discussion Starter #44
Well few updates.

Been having issues with the front o2 giving a "stuck rich signal" CEL, and while CEL is on anytime I go near redline, or even suddenly accelerate(say to pass a car) it'll stumble and act like its running out of gas.
Pretty sure its the o2 sensor that's gone out, so getting it replaced tomorrow.
Hopefully that is all.

No photo, but got a OEM battery back under the hood.
No more green battery.

It's been well over a month since I installed the Godspeed springs, and I haven't noticed anything terrible yet.
Feel just like stock springs, but feels much better in curves.
Occasionally you'll feel a really big dip/pot hole/etc more than you would of with OEM but thats totally acceptable.

Painted the OEM turbo wheels.
Wen't with a Metallic Dark Copper.
Pretty happy with the results.

Also added the 5mm spacers I got while back, love them they push the rear wheels to just about flush with the wheel arch.

Wish I had a before from the rear to compare it to lol

Still need an alignment.. but only notice anything during heavy rain when it puddles on the road.
Hopefully get that done in the next week or two.
Mentioning this, because YES the front right tire has over-spray on it.
It'll be getting replaced soon as the alignment is done.
Not sure why it did when I masked the other 3 just the same.
Anyway.

Pictures.
105231

105232

105233
 

Registered
Joined
44 Posts
Discussion Starter #45
Wow, has it been 3 months already since my last update?
I guess it has.

Well.
In early August ol' Blu went to the track.
105726

Was quite disappointed with my best run being a mere 9.9 in the 1/8th.Later on looking back at time slips, I believe my slow times were due to me launching the car terribly, and making too many runs back to back(heat soak).

We will see in 2 weeks when I go back.


Not much else has changed since then, till this weekend.
3 weeks ago I sold the CNT hot pipe and used that money to buy a 2" HP from Qwik Tyme Performance(Leonard) and got it installed today.
What a difference!
105727
105728

105729


Hoping to have a electric exhaust cut out installed by the upcoming track day.
Should see some gains from dumping the exhaust right after the down pipe.

Had two new tires installed on the rear back in August, finally replaced the worn fronts as well today.
So now the rear are 225/45/18 with 5mm spacers and the fronts are 225/40/18.
Love the way the car sits now(see 'wash' photos below).
Will probably go a little wider on the rear spacers and add 5mm to the front wheels eventually.

Also.. since I hadn't given her a proper bath since the track day(EEK).
She got a bath.
105730
105731

105732

105733




So thats where I am.
I really think I'll see much lower times when I go back to the track, here's to hoping!
 

Registered
Joined
44 Posts
Discussion Starter #46
Oh.

I forgot to document it, but I used pieces of .125" HDPE plastic strips and two-part epoxy to finally permanently fix the damage on the lower left corner of the bumper from the day I brought it home lol

Pretty much I aligned the bumper best I could, used masking tape(on the outside) to keep it together, then used the epoxy and strips of plastic to hold the bumper together, worked amazingly well!
 

Registered
2015 auto VT, 2013 manual VT 脳 2
Joined
3,889 Posts
Let me know if you need track tips! ;-)
 

Registered
2015 RB Accent-not so stock 馃か
Joined
413 Posts
Yeah you better practice up cause my old Cavalier was running consistent 9.3's on an n/a motor with an automatic 4 speed. 馃槀馃し馃徏鈥嶁檪锔忦煒滒煒夝煠
She wasn't stock though as it had an electronic shift kit on the 4t40e tranny with 75% line pressure and full torque converter lockup delay. 馃槈
Here's a video. I'm the blue Cavalier running horrible 9.7's that night due to lots of humidity as it is the Deep South. 馃槈


You'll get in the 8's with your car though. VT's aren't slow and good luck next time you go. 馃憤馃槑
 

Registered
Joined
44 Posts
Discussion Starter #49
Yeah you better practice up cause my old Cavalier was running consistent 9.3's on an n/a motor with an automatic 4 speed. 馃槀馃し馃徏鈥嶁檪锔忦煒滒煒夝煠
She wasn't stock though as it had an electronic shift kit on the 4t40e tranny with 75% line pressure and full torque converter lockup delay. 馃槈
Here's a video. I'm the blue Cavalier running horrible 9.7's that night due to lots of humidity as it is the Deep South. 馃槈


You'll get in the 8's with your car though. VT's aren't slow and good luck next time you go. 馃憤馃槑
Oh I miss Blu.. and one day I'll have a LD9 Jbody again for a "racecar" lol
 

Registered
Joined
44 Posts
Discussion Starter #50 (Edited)
I did some pictures while visiting Johnson City, TN

Really need to;
Repaint wheels
Repaint the silver accents on the ground effects, esp front lip eww

I think I will end up going a few more mm out on the rear wheels and move the 5mm spacers from the rear upfront.
Theres not much room left between the tires and rear fenders, but I think I might be able to fit another 5mm. If not I'll try 3-4mm.

I'm not gonna add any camber, so just going as close as I can without hitting.
Eventually I may grab some front camber/strut bolts and see if I can straighten the front wheels a little.
105760

105761

105762

105763

105764

105765

105766
 

Registered
Joined
44 Posts
Discussion Starter #51
Well got a few things coming in the mail for install hopefully before track day(Sunday).

Pretty sure I already mentioned the new motor mount, if not.. well ordered a new mount to replace the wiggly OEM mount.
Shipping estimate said the 9th-13th.
Really hope it comes Friday or Saturday(9th/10th) so I can get it swapped before Sunday.

Also found a Xentec 8000k HID kit on amazon that was significantly marked down due to damaged packaging.
So I ordered it.
I've seen mixed reviews that say its good, or terrible.
But hey its $20, and since its from Amazon Prime - I can get a refund if it doesn't work.
But I'm sure its worlds better than the OEM style H11 bulbs in there now(swapped to H11 if you missed that),

Also ordered a new cone filter, as the one on the car now is pretty much shot.
But I swapped the intake pieces around and found a much better set up.
Def need to replace the red and black painted(was red) couplers with solid black here one day.
But other wise it seems to look cleaner and fits much neater.
Yeah zipties are a cheap thing to use, but it doesn't move an inch.
There's a thick foam pad attached to the + battery terminal.. thing and the HDPE plastic bracket(where filter is).
I will swap the Zipties out for black once the filter is replaced and I get the whole thing repainted and cleaned up.
105779

105780


Yeah it's still ugly as hell, but it does its job till I can justify dropping the $150+ on a one piece intake over other upgrades/mods that could use that funding lol
 

Registered
Joined
44 Posts
Discussion Starter #52
New motor mount installed, made a huge improvement, more than I expected it too.

New black throttlebody coupler and black filter came in as well.
Looks 100x better IMO now.
105804

105805

105806



Still want to go back in the bay and clean up some more wiring/hoses and move those unsightly ground cables.
 

Registered
Joined
44 Posts
Discussion Starter #54
Well got to the track.

Even though it wasn't near where I was wanting to hit(low 9s).
Every run(except the first as I forgot to turn off traction control) were 9.6.
But that was pretty conservative, launching at only 1k RPMS and full PSI in front tires.
105838

Also had fun as I ran against fully fledged race Foxbody. Smoked me of course lol
Ran a Ford Fusion and a GMC truck and won so there's that lol


Friend gave me a TurboXS Type H BOV, so I ordered the parts to make a cold pipe that will mount the new BOV.
Should have this going first weekend in November(when all the parts show up).
105839


Also had a co-worker use the old OEM mount to make a solid motor mount.
105840

How well it will work, well we'll have to see.
But for the cost(free) vs what a aftermarket costs - it's worth a try!
 

Registered
2015 RB Accent-not so stock 馃か
Joined
413 Posts
Did you even run with that foxbody? 馃ぃ馃槀馃槣馃槼
Man, not even close. 馃馃樂
Nice vids and make me want to go even more to the track.
Im delayed getting home so for now the 1320 is off but the 1/8 mile is still a hopeful when I get home. 馃馃檹馃徑

Btw the 'blu was running consistent 9.4's at the 1/8 mile with a best of 9.31 with a 1.9 60 foot. You better beat those numbers my man or I'll take your man card from you. 馃槀馃槈

Seriously though drag racing was my adrenalin rush before I got heavy into tournament paintball. Now that's the ultimate rush unless you're jumping out of a plane. 馃憤

Loved your post dude and hope to see more. 馃
 

Registered
2015 auto VT, 2013 manual VT 脳 2
Joined
3,889 Posts
Well got to the track.

Even though it wasn't near where I was wanting to hit(low 9s).
Every run(except the first as I forgot to turn off traction control) were 9.6.
But that was pretty conservative, launching at only 1k RPMS and full PSI in front tires.
View attachment 105838
Also had fun as I ran against fully fledged race Foxbody. Smoked me of course lol
Ran a Ford Fusion and a GMC truck and won so there's that lol


Friend gave me a TurboXS Type H BOV, so I ordered the parts to make a cold pipe that will mount the new BOV.
Should have this going first weekend in November(when all the parts show up).
View attachment 105839

Also had a co-worker use the old OEM mount to make a solid motor mount.
View attachment 105840
How well it will work, well we'll have to see.
But for the cost(free) vs what a aftermarket costs - it's worth a try!
Let me know when you want personal lessons in auto VT drag racing :)
 

Registered
Joined
44 Posts
Discussion Starter #57
Sadly really no pictures for this post, but some cool stuff happening.

Ordered everything I need to upgrade the cold pipe, couplers, 2.5" pipe W/ a flange for the new BOV.. and scored a cheap Elantra 60mm throttlebody.

Hopefully everything will arrive by next weekend.
Will get my friend who made the motor mount to make me a block off plate for the OEM BOV location



Also took the solid motor mount for a drive.
Pros;
*Launching is amazing!
*Shifting is amazingly smooth and quick
*Feeling the motor through the chassis is an amazing feeling
Cons;
*LOUD ITS SO FREAKING LOUD!
It's totally impractical for anything beyond a raceday swap out part.
Took it on about 2 hours of errand driving and everyone in the car when we got home had a headache lol
So the OEM will go back in until its needed - luckily it only takes 15 minutes to swap out so easily done upon arriving at a track.
 

Registered
2015 RB Accent-not so stock 馃か
Joined
413 Posts
That solid upper mount really changes the personality of the car for sure.
Mine is loud as well and adding poly exhaust hangers from front to back makes it sound raucous as heck. 馃槀馃槣
Makes it feel I'm in a slow race car. 馃槀馃槈

Good to hear man. Do the coolant bypass on the throttle body if you're not in a cold climate. Ear plugs for the passengers btw. 馃憣馃槈
 
41 - 58 of 58 Posts
Top