Veloster Turbo Forum banner
15121 - 15140 of 15153 Posts

·
Registered
2015 VT M/T Tech
Joined
·
102 Posts
You have an ultra gauge in the same spot as me too.
Great minds 😁 Actually it might have been you who recommended it to me when I first joined... I had it ordered before the car was even delivered but I don't recall how I decided on it. If it was you, thank you! I've put various accessories in and changed my mind and taken them back out many times, but the UG is one thing that I've never had a second thought about - absolutely love it.
 

·
Super Moderator
Joined
·
3,889 Posts
could have been me for sure. i have had mine since 2011 lol
 
  • Like
Reactions: L3g10n

·
Registered
2016 Veloster Turbo DCT Ultimate
Joined
·
326 Posts
In my infuriating quest to make more power with this car... lol I got a boost leak test kit. As well as a 10psi spring for the tial bov. Because we're suspecting my hold up is mechanical.

Theory #1. My tial is connected to the solenoid, with the 6psi spring is slightly open at idle. Not a big problem, but it should be just closed. I know the spring for the tial is more about controlling vacuum vs boost, since under normal conditions, that thing is CLOSED under boost. I suspect that the 6psi spring is getting pushed open somewhere after 24psi and not recovering. Or the solenoid moves the piston and it can't get back closed fast enough. Either way, the 10psi spring should clean that up... if that is the problem. Considering bypassing the solenoid all together and just referencing the IM.

Theory #2. There's a boost leak somewhere else and I'm gonna try to find it. Could be the T for the meth kit. Could be the IC piping. Could be the BOV. Who knows.
 

·
Administrator
2015 auto VT, 2013 manual VT × 2
Joined
·
5,779 Posts
Gotta love boosted platforms and all the complications thrown in.....
 

·
Registered
Joined
·
2 Posts
Finally found well-constructed H11B LEDs that don't require any modification to dust cover or any janky pigtails or conversions... True plug and play. Canadian company, BPS Lighting, 2 year warranty and 2 versions: 1 with 4k lumens per bulb and not DOT approved, one slightly more expensive at 5k lumens per bulb and DOT approved (Canadian DOT, not USDOT); I got the brighter version.
Clean 6500k, matches the halo and accents well, matches my Lasfit SwitchBack fogs on their white setting, clean beam pattern through the projectors, and to my eye about 2.5x the light output of the SilverStar Ultra halogens I had in before. I know a few others who've been running the less expensive ones for over a year now with no issues, so that's promising. No flickering or codes either... So far, highly recommend for anyone who's looking.
Were these actually plug and play? I can't tell from your photos. I'm having issues getting my Lasfit low beams to work on my 2016 Turbo, I think the connection is jenky due to extra cable for Veloster. I'd like to try the bulbs you used; do they just twist right into the same slot as OEM bulb without any adapters? Any info would be greatly appreciated.
 

·
Registered
2015 VT M/T Tech
Joined
·
102 Posts
Were these actually plug and play? I can't tell from your photos. I'm having issues getting my Lasfit low beams to work on my 2016 Turbo, I think the connection is jenky due to extra cable for Veloster. I'd like to try the bulbs you used; do they just twist right into the same slot as OEM bulb without any adapters? Any info would be greatly appreciated.
Yes, these are true plug and play, no adapters!
 

·
Super Moderator
Joined
·
3,889 Posts
those are low beams??

i am running the auxbeam fog, they are much better than the silverstar low beams haha
 

·
Registered
2015 VT M/T Tech
Joined
·
102 Posts
those are low beams??

i am running the auxbeam fog, they are much better than the silverstar low beams haha
Yep, those are H11B low beams!

Awesome, I'm gonna order them. Did you also get their high beams? I had ordered Lasfit high beams, waiting for them to come in to decide if I wanna keep them.
No, I've been Lasfit all the way around in every position other than the low beams for a year (and have been all-Lasfit in every other vehicle I've owned for the past decade), and love them, so see no need to swap out the high beams.
 

·
Administrator
2015 auto VT, 2013 manual VT × 2
Joined
·
5,779 Posts
That should help flow to make more power.
 

·
Administrator
2015 auto VT, 2013 manual VT × 2
Joined
·
5,779 Posts
You're getting there!
 

·
Registered
Joined
·
463 Posts
Oh god, are you trying to out do BTR 2015 500hp SEMA car? And if so, Please let me know if you need another test car, because I would drive out there to hand you over my car keys.:love:
 
  • Like
Reactions: misnblu

·
Administrator
2015 auto VT, 2013 manual VT × 2
Joined
·
5,779 Posts
Oh god, are you trying to out do BTR 2015 500hp SEMA car? And if so, Please let me know if you need another test car, because I would drive out there to hand you over my car keys.:love:
I'm building a car that 500 hp is just the break in power lol. Target is 1k+.....

These will be available to the public once made and tested. Can use plug n play TB from 57 to 80 mm. :cool:

Where dem keys at? Leave the checkbook in the center console! No rubber checks! Hahaha
 

·
Registered
2013 VT, Manual
Joined
·
89 Posts
Broke a wheel stud putting on the winter tires so replaced the stud yesterday.
Tire Wheel Car Vehicle Automotive tire

Tire Wheel Automotive tire Locking hubs Tread

Hand Tire Automotive tire Wheel Automotive lighting
 

·
Super Moderator
Joined
·
3,889 Posts
that sounds fun, did you have to grind down the knuckle and knurl a little bit? i couldn't get the studs in otherwise.
 

·
Registered
2013 VT, Manual
Joined
·
89 Posts
that sounds fun, did you have to grind down the knuckle and knurl a little bit? i couldn't get the studs in otherwise.
I ended up cutting a small section out of that heat shield, with tin snips, so i could get the old stud out and the new stud in. I debated on taking off the hub but decided the hack job was the way to go.
 
15121 - 15140 of 15153 Posts
Top