Veloster Turbo Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter #1
Hello. My car has been having issues starting and today I had to get it towed to the dealership. They called and said my junction box is the culprit in the engine bay. Quoted me a little over 6k for the job to be done. My car has about 88k miles on it and isn’t worth probably more than 7k if it ran. I still owe about 6k on the car. Would I be better off cutting my loses and getting something else. The way I see it I own a useless hunk of metal now. Just trying to get others opinions on this or what I should do...
 

·
Registered
Joined
·
110 Posts
Hello. My car has been having issues starting and today I had to get it towed to the dealership. They called and said my junction box is the culprit in the engine bay. Quoted me a little over 6k for the job to be done. My car has about 88k miles on it and isn’t worth probably more than 7k if it ran. I still owe about 6k on the car. Would I be better off cutting my loses and getting something else. The way I see it I own a useless hunk of metal now. Just trying to get others opinions on this or what I should do...
I'd get a second opinion. Could be solenoids.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #4
That’s what I thought to. Tbh i feel like they really didn’t look at it. They had it for like 3-4 hours and said bad junction box.
 

·
Registered
Joined
·
341 Posts
Also see if the ECU needs to be update if you installed a new battery or starter, that happened to my wife's old Nissan. The ECU was overcharging the battery because it thought that the battery was older.
 
1 - 6 of 6 Posts
Top